Wednesday, February 22, 2012

Calling all J2ME players. I need your help!

I've been struggling for many versions now with problems reported by a lot of players that they can't get Dweller running on their J2ME phones. It seems like the most recent version that worked on all handsets was 1.9.1. In the next version I changed from CLDC 1.0 to CLDC 1.1 to be able to use floating point numbers for UI scale and alpha values. I believe it is this change that for some reason has been causing a lot of problems for some players. The problem seems to primarily exists on Nokia devices. Sony Ericsson is running Dweller just fine and I haven't heard of other devices that haven't been able to run Dweller.

Tonight I decided to revert back to fixed point math for scaling and alpha and by doing so it was possible to go back to CLDC 1.0 again. I also had to change my logging since something like LoggerFactory.getLogger(MyClass.class) doesn't work on CLDC 1.0 due to the fact that NoClassDefFoundError isn't included in CLDC 1.0

I am now hoping that as many J2ME users as possible out there would like to help me test the new version and verify if Dweller is running on their devices. Please try http://files.dwellergame.com/j2me/Dweller.jar (version 1.16.8) and let me know if it works or not

2 comments:

  1. Works on Blackberry 9930, but that is not saying much because 1.16.7 worked great as well.

    ReplyDelete
  2. Bob, thank you for the reply. I'm glad to hear that Dweller works well on your Blackberry. I had problems with Blackberry devices in the past, but it's good to know that the game is still running perfectly fine on Blackberries.

    ReplyDelete